WPLounge
Classic Editor ondersteuning
Home » WordPress Plugins » Classic Editor-plugin wordt nog jaren ondersteund

Classic Editor-plugin wordt nog jaren ondersteund

Goed nieuws voor WordPress-gebruikers die (nog) niet over willen op Gutenberg: WordPress zal de Classic Editor-plugin blijven ondersteunen.

Affiliate disclaimer:
In onze artikelen en op onze pagina's staan affiliate links. Wanneer je via één van deze links een aankoop doet, ontvangen wij een (meestal kleine) commissie van de verkoper. Wij geven altijd onze eerlijke mening over producten. Klik hier voor meer informatie.

Dit zei Matt Mullenweg in een reactie op de website WPTavern. Hij geeft aan dat de Classic Editor nog jaren ondersteund zal blijven worden:

I won’t say “forever” but I don’t see any reason why we can’t maintain classic for the edit screen for many years to come.

En dat is goed nieuws voor de vele WordPress-gebruikers die Gutenberg niet prettig vinden werken, of om een andere reden nog niet over willen op Gutenberg. Bij WPLounge krijgen we regelmatig vragen en opmerkingen van WordPress-gebruikers waarbij Gutenberg nog niet (goed) werkt. Ze maken zich vaak zorgen dat zij straks “gedwongen” zullen worden om bepaalde plugins en themes te verwijderen omdat deze niet met Gutenberg werken.

TIP VAN WPLOUNGE
Divi theme & Divi Builder
Bij Elegant Themes ontvang je meer dan
85 premium themes (waaronder Divi!) voor maar 89 dollar!
Bekijk de themes »
Lees meer over Divi.

Classic Editor en TinyMCE

Net als de Classic Editor gebruikt Gutenberg TinyMCE, de populaire WYSIWYG-HTML-Editor. Het is voor het WordPress-team dan ook weinig extra werk om eventuele updates van TinyMCE óók beschikbaar te maken in de Classic Editor-plugin.

Naast het feit dat ondersteuning voor de Classic Editor voorlopig gewoon doorgaat, geeft Mullenweg aan dat hij het mooi vindt dat zo veel mensen de Classic Editor-plugin gebruiken:

I love that people are using the Classic Editor plugin! There is an infinite number of ways that WP can be used and not all will be ready for Gutenberg when 5.0 is released.

Developers van plugins en themes zullen hierdoor de keuze kunnen maken of ze Gutenberg volledig gaan ondersteunen. Dit zal natuurlijk ook grotendeels afhankelijk zijn van het aantal gebruikers dat de Classic Editor-plugin installeert, vooral nadat WordPress 5.0 wordt gereleased.

Gutenberg
Gutenberg

Plugins en themes

Dat WordPress zelf nog jaren ondersteuning zal bieden voor de Classic Editor, betekent helaas niet dat alle plugin- en theme-developers dit óók zullen doen. De ondersteuning van de Classic Editor zal sterk afhangen van het aantal actieve installaties. De verwachting is natuurlijk dat het aantal gebruikers van de Classic Editor langzaam zal afnemen. Het zou dan ook logisch zijn als steeds meer plugin- en theme-ontwikkelaars er dan voor kiezen om alléén Gutenberg te ondersteunen.

Gutenberg gebruiken of nog even wachten?

Veel gebruikers twijfelen over de overstap naar Gutenberg. Ik zelf bekijk het per website. Op WPLounge.nl werkt Gutenberg (nog) niet helemaal goed, dus gebruik ik voorlopig de Classic Editor. Op andere websites gebruik ik juist wél Gutenberg, omdat het daar veel beter werkt dan de “oude” editor.

Om te bepalen of Gutenberg geschikt is voor jouw website, kun je het beste een kopie maken van je website om vervolgens te testen of Gutenberg goed werkt.

Lees ook:

 

Beoordeel dit artikel

(2 ratings, gemiddeld: 5,00 van de 5)
Wouter Postma

Wouter Postma

Eigenaar van WPLounge. Blogt ook in het Engels op WPLounge.org.

Gratis op de hoogte blijven?

Meld je gratis aan voor onze nieuwsbrief om op de hoogte
te blijven over ontwikkelingen in WordPress!

Reageer

Advertenties

Blijf op de hoogte!