WPLounge
Home » WordPress Algemeen » WordPress 5.1 gaat waarschuwen voor oude PHP versie

WordPress 5.1 gaat waarschuwen voor oude PHP versie

WordPress zal de aankomende tijd meldingen vertonen aan beheerders van websites die op oudere PHP-versies draaien. Dit heeft Felix Arntz bekendgemaakt via een blogpost. WordPress zal vanaf april alleen nog PHP-versie 5.6 of nieuwer ondersteunen.

Deze melding is een onderdeel van de Site Health Check. WordPress wil de prestaties en stabiliteit van het WordPressecosysteem perfectioneren. De melding komt voor veel WordPress gebruikers als een verrassing, omdat de minimale PHP-versie al jaren niet is veranderd.

Affiliate disclaimer:
In onze artikelen en op onze pagina's staan affiliate links. Wanneer je via één van deze links een aankoop doet, ontvangen wij een (meestal kleine) commissie van de verkoper. Wij geven altijd onze eerlijke mening over producten. Klik hier voor meer informatie.

PHP versie 5.6 of lager?

Verschillende websites ontvangen de melding over het vernieuwen van de PHP-versie. Het gaat dan om de websites die gebruik maken van PHP-versie 5.6 of lager. De laagste PHP-versie die beveiligingsupdates ontvangt is op dit moment versie 7.1. WordPress wil dat PHP-versie 5.6 de beoogde versie wordt. Deze beslissing is in 2018 gemaakt, na de uitgave van WordPress 5.0. Gary Pendergast van WordPress meldt dat ongeveer 85% van de websites met WordPress 5.0 op een PHP-versie van 5.6 of nieuwer draait. Slechts een klein aantal actieve gebruikers ontvangt de melding van het vernieuwen van de PHP-versie. Er zijn namelijk miljoenen sites die op oude WordPress-versies draaien, die of vergeten of opgegeven zijn. 

PHP waarschuwing WordPress 5.1
Snapshot WordPress 5.1 waarschuwing

Het is de bedoeling dat zoveel mogelijk actieve gebruikers overstappen naar een recentere PHP-versie. Hierdoor kan WordPress de ondersteuning voor oudere PHP-versies laten vallen.

TIP VAN WPLOUNGE
Divi theme & Divi Builder
Bij Elegant Themes ontvang je meer dan
85 premium WordPress themes (waaronder Divi!) voor maar 89 dollar!
Bekijk de themes »»
Lees meer over Divi.

Is updaten naar een hogere PHP versie moeilijk?

Het updaten van de PHP-versie is in de meeste gevallen redelijk eenvoudig. Populaire plug-ins en thema’s worden bijvoorbeeld goed onderhouden, waardoor deze niet vaak voor problemen zullen zorgen. Updaten is in de meeste gevallen te doen rechtstreeks vanuit de Direct Admin, onder domeinbeheer.

PHP versie terugzetten in DA

Daarentegen zijn niet alle extensies bruikbaar met de nieuwste PHP-versies. Het kan zijn dat een plug-in of thema ervoor zorgt dat de WordPress-site niet meer toegankelijk is, door middel van het updaten van de PHP-versie. De website geeft hierdoor een error 500 code aan. In dit artikel gaan we in op mogelijke oplossingen voor een error 500 code.

In de melding staat een link naar de WordPress support pagina, waarin het probleem kort uitgelegd wordt. Vervolgens wordt er gekeken naar hoe de website voor te bereiden is op de WordPress 5.1 update, die 21 februari zal plaatsvinden. WordPress wil dat in december 2019 PHP-versie 7.0 de minimum PHP-versie is.

Beoordeel dit artikel

(Nog geen ratings)

Roger Overdevest

Roger is eigenaar van de website WPLounge en van zoekmachine marketing bureau Kliq Internet

Gratis op de hoogte blijven?

Meld je gratis aan voor onze nieuwsbrief om op de hoogte
te blijven over ontwikkelingen in WordPress!

Reageer

Advertenties

Blijf op de hoogte!

Scroll Up
Skip to content